#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)[a-z]+" & @CRLF & _
"# you mean like this?" & @CRLF & _
"#\ (?:\d{4,5}(?=\.\d{2}))" & @CRLF & _
"# only downside is you have to escape spaces"
Local $sString = "now you can has other regeex parts unused 1234.12"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")