import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-z]+\n"
+ "# you mean like this?\n"
+ "#\\ (?:\\d{4,5}(?=\\.\\d{2}))\n"
+ "# only downside is you have to escape spaces";
final String string = "now you can has other regeex parts unused 1234.12";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}