re = /[a-z]+
# you mean like this?
#\ (?:\d{4,5}(?=\.\d{2}))
# only downside is you have to escape spaces/mx
str = 'now you can has other regeex parts unused 1234.12'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end