const regex = /[a-z]+
# you mean like this?
#\ (?:\d{4,5}(?=\.\d{2}))
# only downside is you have to escape spaces/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-z]+
# you mean like this?
#\\ (?:\\d{4,5}(?=\\.\\d{2}))
# only downside is you have to escape spaces', 'gm')
const str = `now you can has other regeex parts unused 1234.12`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}