$re = '/[a-z]+
# you mean like this?
#\ (?:\d{4,5}(?=\.\d{2}))
# only downside is you have to escape spaces/mx';
$str = 'now you can has other regeex parts unused 1234.12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);