using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-z]+
# you mean like this?
#\ (?:\d{4,5}(?=\.\d{2}))
# only downside is you have to escape spaces";
string input = @"now you can has other regeex parts unused 1234.12";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}