// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)[a-z]+
# you mean like this?
#\ (?:\d{4,5}(?=\.\d{2}))
# only downside is you have to escape spaces").unwrap();
let string = "now you can has other regeex parts unused 1234.12";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}