#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z0-9_]*(?:[a-zA-Z][a-zA-Z0-9_]*){2,}\d{3}[a-zA-Z]{1,2}$"
Local $sString = "6C1Q6K271BH" & @CRLF & _
" //это должно пройти проверку" & @CRLF & _
"" & @CRLF & _
"038103469AD" & @CRLF & _
" // это не должно " & @CRLF & _
"" & @CRLF & _
"038103469AE" & @CRLF & _
" // это не должно " & @CRLF & _
"" & @CRLF & _
"03G103469H" & @CRLF & _
" // это не должно " & @CRLF & _
"" & @CRLF & _
"4M5G6K272HE" & @CRLF & _
" //это должно пройти проверку" & @CRLF & _
"" & @CRLF & _
"5M5G6K272H" & @CRLF & _
" //это должно пройти проверку"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")