use strict;
my $str = '6C1Q6K271BH
//это должно пройти проверку
038103469AD
// это не должно
038103469AE
// это не должно
03G103469H
// это не должно
4M5G6K272HE
//это должно пройти проверку
5M5G6K272H
//это должно пройти проверку';
my $regex = qr/^[a-zA-Z0-9_]*(?:[a-zA-Z][a-zA-Z0-9_]*){2,}\d{3}[a-zA-Z]{1,2}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}