import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z0-9_]*(?:[a-zA-Z][a-zA-Z0-9_]*){2,}\\d{3}[a-zA-Z]{1,2}$";
final String string = "6C1Q6K271BH\n"
+ " //это должно пройти проверку\n\n"
+ "038103469AD\n"
+ " // это не должно \n\n"
+ "038103469AE\n"
+ " // это не должно \n\n"
+ "03G103469H\n"
+ " // это не должно \n\n"
+ "4M5G6K272HE\n"
+ " //это должно пройти проверку\n\n"
+ "5M5G6K272H\n"
+ " //это должно пройти проверку";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}