// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z0-9_]*(?:[a-zA-Z][a-zA-Z0-9_]*){2,}\d{3}[a-zA-Z]{1,2}$").unwrap();
let string = "6C1Q6K271BH
//это должно пройти проверку
038103469AD
// это не должно
038103469AE
// это не должно
03G103469H
// это не должно
4M5G6K272HE
//это должно пройти проверку
5M5G6K272H
//это должно пройти проверку";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}