using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z0-9_]*(?:[a-zA-Z][a-zA-Z0-9_]*){2,}\d{3}[a-zA-Z]{1,2}$";
string input = @"6C1Q6K271BH
//это должно пройти проверку
038103469AD
// это не должно
038103469AE
// это не должно
03G103469H
// это не должно
4M5G6K272HE
//это должно пройти проверку
5M5G6K272H
//это должно пройти проверку";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}