using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^DFIOQUWZ]\d[ABCEGHJ-NPRSTV-Z][\s|\-]?\d[ABCEGHJ-NPRSTV-Z]\d";
string input = @"h1bl3c
H1V 2M2
h1bl3c
m3S34s
m4e3s5
H1VeM2
M4M-2N2
m4m 2n2
H0H 0H0";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}