package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[^DFIOQUWZ]\d[ABCEGHJ-NPRSTV-Z][\s|\-]?\d[ABCEGHJ-NPRSTV-Z]\d`)
var str = `h1bl3c
H1V 2M2
h1bl3c
m3S34s
m4e3s5
H1VeM2
M4M-2N2
m4m 2n2
H0H 0H0`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}