import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^DFIOQUWZ]\\d[ABCEGHJ-NPRSTV-Z][\\s|\\-]?\\d[ABCEGHJ-NPRSTV-Z]\\d";
final String string = "h1bl3c\n"
+ "H1V 2M2\n"
+ "h1bl3c\n"
+ "m3S34s\n"
+ "m4e3s5\n"
+ "H1VeM2\n"
+ "M4M-2N2\n"
+ "m4m 2n2\n"
+ "H0H 0H0";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}