const regex = /[^DFIOQUWZ]\d[ABCEGHJ-NPRSTV-Z][\s|\-]?\d[ABCEGHJ-NPRSTV-Z]\d/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^DFIOQUWZ]\\d[ABCEGHJ-NPRSTV-Z][\\s|\\-]?\\d[ABCEGHJ-NPRSTV-Z]\\d', 'i')
const str = `h1bl3c
H1V 2M2
h1bl3c
m3S34s
m4e3s5
H1VeM2
M4M-2N2
m4m 2n2
H0H 0H0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}