$re = '/[^DFIOQUWZ]\d[ABCEGHJ-NPRSTV-Z][\s|\-]?\d[ABCEGHJ-NPRSTV-Z]\d/i';
$str = 'h1bl3c
H1V 2M2
h1bl3c
m3S34s
m4e3s5
H1VeM2
M4M-2N2
m4m 2n2
H0H 0H0';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);