import re
regex = re.compile(r"[^DFIOQUWZ]\d[ABCEGHJ-NPRSTV-Z][\s|\-]?\d[ABCEGHJ-NPRSTV-Z]\d", flags=re.IGNORECASE)
test_str = ("h1bl3c\n"
"H1V 2M2\n"
"h1bl3c\n"
"m3S34s\n"
"m4e3s5\n"
"H1VeM2\n"
"M4M-2N2\n"
"m4m 2n2\n"
"H0H 0H0")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")