import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[.*\\]\\((?!http:)(?!.+\\.md).+\\)";
final String string = "dfg [link text 3](http://external-link...md) fgdfg\n"
+ "dfg [link text 3](http://external-link/file.ext) dfg\n"
+ "dfg [link text 3](http://external-link/file.) dfg\n"
+ "dfg [link text 3](http://external-link) dfg\n"
+ "dfg [link text 1](internal-link) dfgdg\n"
+ "dfg [link text 1](internal-link.) dfgdg\n"
+ "dfg [link text 2](internal-link-2.md) dfgdg\n"
+ "dfg [link text 2](internal-link-2.mdsdfsdf) dfgdg\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}