import Foundation
let pattern = #"\[.*\]\((?!http:)(?!.+\.md).+\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
dfg [link text 3](http://external-link...md) fgdfg
dfg [link text 3](http://external-link/file.ext) dfg
dfg [link text 3](http://external-link/file.) dfg
dfg [link text 3](http://external-link) dfg
dfg [link text 1](internal-link) dfgdg
dfg [link text 1](internal-link.) dfgdg
dfg [link text 2](internal-link-2.md) dfgdg
dfg [link text 2](internal-link-2.mdsdfsdf) dfgdg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)