import re
regex = re.compile(r"\[.*\]\((?!http:)(?!.+\.md).+\)", flags=re.MULTILINE)
test_str = ("dfg [link text 3](http://external-link...md) fgdfg\n"
"dfg [link text 3](http://external-link/file.ext) dfg\n"
"dfg [link text 3](http://external-link/file.) dfg\n"
"dfg [link text 3](http://external-link) dfg\n"
"dfg [link text 1](internal-link) dfgdg\n"
"dfg [link text 1](internal-link.) dfgdg\n"
"dfg [link text 2](internal-link-2.md) dfgdg\n"
"dfg [link text 2](internal-link-2.mdsdfsdf) dfgdg\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")