const regex = /\[.*\]\((?!http:)(?!.+\.md).+\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[.*\\]\\((?!http:)(?!.+\\.md).+\\)', 'gm')
const str = `dfg [link text 3](http://external-link...md) fgdfg
dfg [link text 3](http://external-link/file.ext) dfg
dfg [link text 3](http://external-link/file.) dfg
dfg [link text 3](http://external-link) dfg
dfg [link text 1](internal-link) dfgdg
dfg [link text 1](internal-link.) dfgdg
dfg [link text 2](internal-link-2.md) dfgdg
dfg [link text 2](internal-link-2.mdsdfsdf) dfgdg
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}