$re = '/\[.*\]\((?!http:)(?!.+\.md).+\)/m';
$str = 'dfg [link text 3](http://external-link...md) fgdfg
dfg [link text 3](http://external-link/file.ext) dfg
dfg [link text 3](http://external-link/file.) dfg
dfg [link text 3](http://external-link) dfg
dfg [link text 1](internal-link) dfgdg
dfg [link text 1](internal-link.) dfgdg
dfg [link text 2](internal-link-2.md) dfgdg
dfg [link text 2](internal-link-2.mdsdfsdf) dfgdg
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);