# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([A-Z]+)/\L$1/g;t' <<< "ASDSADSAadfasdf9080DSAD908fgsd"