const regex = /([A-Z]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Z]+)', 'g')
const str = `ASDSADSAadfasdf9080DSAD908fgsd`;
const subst = `\L$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);