re = /([A-Z]+)/
str = 'ASDSADSAadfasdf9080DSAD908fgsd'
subst = '\\L$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result