use strict;
my $str = 'ASDSADSAadfasdf9080DSAD908fgsd';
my $regex = qr/([A-Z]+)/p;
my $subst = '\\L$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";