package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([A-Z]+)`)
var str = `ASDSADSAadfasdf9080DSAD908fgsd`
var substitution = "\L$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}