$re = '/([A-Z]+)/';
$str = 'ASDSADSAadfasdf9080DSAD908fgsd';
$subst = "\L$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;