#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^,]*[A-Za-z0-9]{5}[^,]*"
Local $sString = "Accounts Payable Goods for Resale" & @CRLF & _
"Corporate Finance, Financial Engineering," & @CRLF & _
"TBD," & @CRLF & _
"Goods for Not Resale, SAP," & @CRLF & _
"Jack Ryan, Tom O," & @CRLF & _
"Stack Over Flow, StackOverFlow," & @CRLF & _
"Jurassic Park, IT" & @CRLF & _
"GOT"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")