import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^,]*[A-Za-z0-9]{5}[^,]*";
final String string = "Accounts Payable Goods for Resale\n"
+ "Corporate Finance, Financial Engineering,\n"
+ "TBD,\n"
+ "Goods for Not Resale, SAP,\n"
+ "Jack Ryan, Tom O,\n"
+ "Stack Over Flow, StackOverFlow,\n"
+ "Jurassic Park, IT\n"
+ "GOT";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}