re = /[^,]*[A-Za-z0-9]{5}[^,]*/m
str = 'Accounts Payable Goods for Resale
Corporate Finance, Financial Engineering,
TBD,
Goods for Not Resale, SAP,
Jack Ryan, Tom O,
Stack Over Flow, StackOverFlow,
Jurassic Park, IT
GOT'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end