// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[^,]*[A-Za-z0-9]{5}[^,]*").unwrap();
let string = "Accounts Payable Goods for Resale
Corporate Finance, Financial Engineering,
TBD,
Goods for Not Resale, SAP,
Jack Ryan, Tom O,
Stack Over Flow, StackOverFlow,
Jurassic Park, IT
GOT";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}