import Foundation
let pattern = #"[^,]*[A-Za-z0-9]{5}[^,]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Accounts Payable Goods for Resale
Corporate Finance, Financial Engineering,
TBD,
Goods for Not Resale, SAP,
Jack Ryan, Tom O,
Stack Over Flow, StackOverFlow,
Jurassic Park, IT
GOT
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)