package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^,]*[A-Za-z0-9]{5}[^,]*`)
var str = `Accounts Payable Goods for Resale
Corporate Finance, Financial Engineering,
TBD,
Goods for Not Resale, SAP,
Jack Ryan, Tom O,
Stack Over Flow, StackOverFlow,
Jurassic Park, IT
GOT`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}