# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<a[^>]+href=)(?:"https?:\\/\\/[^">]+"|'https?:\\/\\/[^>']+')([^>]+>)/$1"#"$2/gmius;t' <<< " Текст <a href=\"http://garlando.ru/shop/385/desc/nastolnyj-futbol-garlando-master-champion\" target=\"_self\">Ссылка</a>\".
"