$re = '/(<a[^>]+href=)(?:"https?:\/\/[^">]+"|\'https?:\/\/[^>\']+\')([^>]+>)/mius';
$str = ' Текст <a href="http://garlando.ru/shop/385/desc/nastolnyj-futbol-garlando-master-champion" target="_self">Ссылка</a>".
';
$subst = "$1\"#\"$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;