package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mis)(<a[^>]+href=)(?:"https?:\/\/[^">]+"|'https?:\/\/[^>']+')([^>]+>)`)
var str = ` Текст <a href="http://garlando.ru/shop/385/desc/nastolnyj-futbol-garlando-master-champion" target="_self">Ссылка</a>".
`
var substitution = "$1"#"$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}