const regex = /(<a[^>]+href=)(?:"https?:\/\/[^">]+"|'https?:\/\/[^>']+')([^>]+>)/gmius;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<a[^>]+href=)(?:"https?:\\\/\\\/[^">]+"|\'https?:\\\/\\\/[^>\']+\')([^>]+>)', 'gmius')
const str = ` Текст <a href="http://garlando.ru/shop/385/desc/nastolnyj-futbol-garlando-master-champion" target="_self">Ссылка</a>".
`;
const subst = `$1"#"$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);