import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<a[^>]+href=)(?:\"https?:\\/\\/[^\">]+\"|'https?:\\/\\/[^>']+')([^>]+>)";
final String string = " Текст <a href=\"http://garlando.ru/shop/385/desc/nastolnyj-futbol-garlando-master-champion\" target=\"_self\">Ссылка</a>\".\n";
final String subst = "$1\"#\"$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}