#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mius)(<a[^>]+href=)(?:"https?:\/\/[^">]+"|'https?:\/\/[^>']+')([^>]+>)"
Local $sString = " Текст <a href="http://garlando.ru/shop/385/desc/nastolnyj-futbol-garlando-master-champion" target="_self">Ссылка</a>"." & @CRLF & _
""
Local $sSubst = "$1"#"$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)