using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<a[^>]+href=)(?:""https?:\/\/[^"">]+""|'https?:\/\/[^>']+')([^>]+>)";
string substitution = @"$1""#""$2";
string input = @" Текст <a href=""http://garlando.ru/shop/385/desc/nastolnyj-futbol-garlando-master-champion"" target=""_self"">Ссылка</a>"".
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.CultureInvariant | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}