const regex = /https:\/\/[\s\S]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/[\\s\\S]*', 'g')
const str = `The test has some url in the last. extract the text starting from https to the end of the string<br></br>https://xyz.com/index.html`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}