re = /https:\/\/[\s\S]*/
str = 'The test has some url in the last. extract the text starting from https to the end of the string<br></br>https://xyz.com/index.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end