import re
regex = re.compile(r"https:\/\/[\s\S]*")
test_str = "The test has some url in the last. extract the text starting from https to the end of the string<br></br>https://xyz.com/index.html"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")