package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)<div class="row">[\n\s]*<div class="col-md-6">[^<]*<\/div>[ \n\s]*<\/div>`)
var str = `<div class="container header">
<div class="row">
<div class="col-md-6">This is the target text</div>
</div>
</div><span /><a href...></a>Whatever
<div class="container header">
<div class="row">
<div class="col-md-6">This is the target text</div>
</div>
</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}