const regex = /<div class="row">[\n\s]*<div class="col-md-6">[^<]*<\/div>[ \n\s]*<\/div>/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div class="row">[\\n\\s]*<div class="col-md-6">[^<]*<\\\/div>[ \\n\\s]*<\\\/div>', 'gs')
const str = `<div class="container header">
<div class="row">
<div class="col-md-6">This is the target text</div>
</div>
</div><span /><a href...></a>Whatever
<div class="container header">
<div class="row">
<div class="col-md-6">This is the target text</div>
</div>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}