import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div class=\"row\">[\\n\\s]*<div class=\"col-md-6\">[^<]*<\\/div>[ \\n\\s]*<\\/div>";
final String string = "<div class=\"container header\">\n"
+ " <div class=\"row\">\n"
+ " <div class=\"col-md-6\">This is the target text</div>\n"
+ " </div>\n"
+ "</div><span /><a href...></a>Whatever\n"
+ "<div class=\"container header\">\n"
+ " <div class=\"row\">\n"
+ " <div class=\"col-md-6\">This is the target text</div>\n"
+ " </div>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}