// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)<div class="row">[\n\s]*<div class="col-md-6">[^<]*<\/div>[ \n\s]*<\/div>"#).unwrap();
let string = "<div class=\"container header\">
<div class=\"row\">
<div class=\"col-md-6\">This is the target text</div>
</div>
</div><span /><a href...></a>Whatever
<div class=\"container header\">
<div class=\"row\">
<div class=\"col-md-6\">This is the target text</div>
</div>
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}