use strict;
my $str = '<div class="container header">
<div class="row">
<div class="col-md-6">This is the target text</div>
</div>
</div><span /><a href...></a>Whatever
<div class="container header">
<div class="row">
<div class="col-md-6">This is the target text</div>
</div>
</div>';
my $regex = qr/<div class="row">[\n\s]*<div class="col-md-6">[^<]*<\/div>[ \n\s]*<\/div>/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}